Vcenter Server 7 Yükseltme Öncesi Bilinmesi Gerekenler Nelerdir?

Merhaba, bu yazımda sizlere mevcut Vcenter Server 7 Yükseltme Öncesi Bilinmesi Gerekenler Nelerdir? kısmını anlatacağım. Her şeyden önce bilmeniz gereken en önemli ayrıntı Vcenter Server 7 versiyonu ile birlikte bundan böyle Windows Vcenter Server kullanamıyoruz. Eğer altyapınız için yeni bir kurulum yapacaksanız, bu kurulum mutlaka Vcenter Server Appliance olmalıdır.

Hemen küçük bir hatırlatma daha yapalım. Vcenter Server Appliance üzerinde Photon işletim sistemi bulunmaktadır. Windows Vcenter Server kurulumu 6.7 versiyonundan sonra bir daha görülmeyecektir. Vcenter Server 7 üzerinde gelen yeni bir özellikte sadece embedded PSC yöntemi ile kurulum yapabiliyor oluşunuzdur.

Önceki Vcenter versiyonlarında yükseltme yaparken önce, convergence tool çalıştırarak embedded yapıp sonrasında upgrade işlemi başlatabiliyorduk. Ancak Vcenter Server 7 ile gelen yeni özellik sayesinde Vcenter server 6.5 ya da Vcenter Server 6.7 üzerinden embedded PSC ile kolay ve hızlı bir şekilde migration işlemi başlatılabilmektedir. Ayrıca önemli bir detayı daha verelim. Bu işlemi Windows Vcenter Server versiyonunu Vcenter Server Appliance versiyonuna migration yaparken de kullanabilirsiniz. Tam burada PSC dediğimiz Platform Services Controller’ın ne anlama geldiğinden ve ne işe yaradığından bahsedeceğim.

Platform Services Controller Nedir?

PSC denilen tanımı Vsphere 6.0 versiyonu ile duymaya başlamıştık. Aslında Vmware üzerinde bulunmakta olan servislerin iki hizmette toplanması diyebiliriz. Bu da Vcenter ve Platform Services Controller olarak bilinmektedir. Vmware; 6.7 GA sürümü sonrasındaki versiyonlarda external PSC’nin desteklenmeyeceğini duyurdu. Bununla birlikte de Convergence Tool yayınlanmıştır. Gelmiş olduğumuz bu noktada ise Photon OS ile desteklenmiş olan Vcenter Server Appliance ve embedded deployment şekli hayatımızı inanılmaz kolaylaştırmaktadır.

Eğer external deployment tipine sahip iseniz; permission, user database, lisans ve AD üyeliği gibi bilgilerinizi koruyarak, embedded PSC tipine geçiş yapabilirsiniz. Bunu yapabilmek için de Vcenter 6.5 u2d versiyonu ile 6.7 u1 versiyon ISO dosyaları içerisinde converge tool bulunmaktadır. Bu mükemmel ve kullanışlı tool sayesinde öncelikle mevcut external PSC tipiniz embedded duruma getirilmektedir. Ardından ihtiyacımız olmayan external PSC ise unregister duruma getirilmektedir. Ayrıca ISO içindeki tool olmadan sadece GUI arayüzü kullanarak ta bu işlemi gerçekleştirebilirsiniz.

Kısaca tool ile ilgili bahsetmek gerekirse; indirmiş olduğunuz ISO dosyası içerisinde “vcsa-converge-cli” dosyasının olduğunun göreceksiniz. Bu dosya içerisinde templates altına giriş yapıyoruz. Burada converge ve decommission adında iki klasör göreceksiniz. Bu işleme başlamadan önce yapmanız gereken çok önemli bir nokta daha bulunmaktadır. Eğer cluster’larınız üzerinde DRS kullanıyorsanız, bunu manual moda getirmelisiniz. Yine işleme başlamadan önce memory seçeneğini işaretlemeden bir snapshot almanız önerilmektedir.

Bunun ardından klasör içerisinde converge.json yapacağımız ayarlarımızı girmeliyiz. Burada bütün bilgiler yer almaktadır. Bunları kendi ortamımıza göre doğru bir şekilde düzenliyoruz. Path içerisine dosyamızı kaydediyoruz. Bundan sonra cmd komut satırı içerisine giriş yapıyoruz. Ardından ISO dosyamız içerisinde vcsa-converge-cli\win32 yoluna gidiyoruz. Ve aşağıdaki komut ile converge işlemimizi başlatmış oluyoruz.

vcsa-util.exe converge –no-ssl-certificate-verification –backup-taken –verbose C:\dosyayınereyekaydettiyseniz\converge.json

En son “y” ile restart etmemiz gerekecek. Converge işleminden sonra Vmware üzerindeki login, lisans bilgileriniz ve permission gibi alanları kontrol etmenizde fayda bulunmaktadır. İşlemleri bitirdikten sonra eski PSC’nizi de decommission etmeniz gerekmektedir. Bunu da aşağıdaki komut ile gerçekleştirebilirsiniz.

Vcsa-util.exe decommission –no-ssl-certificate-verification –verbose C:\dosyaneredeise\decommision.json

Vcenter Server 7 Geçiş Öncesi

Yukarıda oldukça önemli kısımlarından bahsetmiş olduğumuz Vcenter Server 7 upgrade öncesi PSC versiyonlarına dikkat çekmek istedik. Önemli ve mutlak kontrol etmeniz gereken şey ise upgrade ettikten sonra eski PSC’nizi devre dışı bırakmak olacaktır. Converge tool ile gerçekleştirdiğimiz bu işlem maalesef, PSC’nizi otomatik olarak pasif hale getirmeyecektir.

Son olarak bir önemli şey daha söyleyelim. Vcenter Server 7 versiyonuna geçiş yapmadan önce dikkat etmeniz gereken bir husus daha var. O da elbette ki uyumluluk yani Compatability Guide incelemek olacaktır. Uyumsuzluk sorunları Vmware altyapınızı yönetmenize bile engel olabilmektedir. Unutmamanız gereken son husus ta; Vsphere 6.5 ya da Vsphere 6.7 sürümlerinden birine sahipseniz, direkt olarak Vsphere 7 versiyonuna geçiş yapabileceğinizdir. Vcenter Server Appliance versiyonunu 6.0 üzerine kuramazsınız. En düşük 6.5 versiyonuna sahip olmanız gerekmektedir.

Bu yazımda, Platform Services Controller’ın tanımından, converge tool nasıl çalıştıracağınızdan, Vcenter Server 7 versiyonuna geçiş yapmadan önce nelere dikkat etmeniz gerektiğini anlatmaya çalıştım. Umarım faydalı olmuştur.


 

Dağcan Nural

1988 İstanbul doğumluyum. Bilgisayar dünyasına olan hayranlığım çok küçük yaşlarda başladı. Bu sebeple sistem alanında kendimi geliştirmeye karar verdim. Celal Bayar Üniversitesi Bilgisayar Programcılığı ve Anadolu Üniversitesi İşletme mezunuyum. 2005 yılında Bilge Adam Sistem & Network Mühendisliği eğitimi aldım. Hemen ardından IT dünyasına giriş yaptım. Collezione şirketinde 2006 - 2018 yılları arasında Sistem Uzmanı olarak görev yaptım. 2018 Temmuz ayından beri LCWAIKIKI şirketinde IT System Engineer pozisyonunda çalışmaktayım. Sektörde 14 yıllık deneyime sahibim. Birçok önemli projede görev aldım. Sayfanın en alt kısmından Linkedin profilime ulaşabilirsiniz. Bilgi ve tecrübemi hem bu blog üzerinde hem de Çözümpark Bilişim Portalı üzerinde paylaşıyorum. Bilgi paylaştıkça güzeldir.

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir